Titans of Ether (http://cfkasper.de/ultima/board/index.php)
- ULTIMA (http://cfkasper.de/ultima/board/board.php?boardid=11)
-- Utlima 5 (http://cfkasper.de/ultima/board/board.php?boardid=59)
--- Keyboard bug (http://cfkasper.de/ultima/board/thread.php?threadid=929)

Posted by Sunigator on 01-07-2021 at01:09:

  Keyboard bug

Can someone help me with a little problem I'm having with U5 ?
Here is its description: I can't use anymore the keys 1-2-3-4-6-7-8-9 from the keyboard, only the 5 and 0 work. They worked perfectly until today!
This is bad because when the game asks how many hours I want to rest, or how many spells I want to mix, I can only say 5 or quit (using 0).
Quitting the game and then reloading doesn't help.
I'm playing U5 using DosBox 0.63, and the Amiga music patch.
Any suggestion is welcome! Pleased

Posted by Thanatloc on 02-07-2021 at11:55:


Well, to begin with, one must know where is the problem exactly. Then, does it happen with any application or game under DosBox or only with U5?

If it is only with U5, perhaps that can be solved with a re-installation of the game (of course preserve first your savegame.)

If it happens with any application under DosBox, it is most surely that the config files are corrupted (resulting of possible unstability of the 0.63 DosBox version.) In this case, you can install the latest version of Dosbox, or try it dirty by looking the config files of your 0.63 version...

Good luck

(If none of the above works, and if you possess Dungeon Siege, you can try U5: lazarus because it is great as well)

Posted by Tribun Dragon on 05-07-2021 at23:05:


Very well known problem.

Deactivate Num Lock before starting the game, this will solve the problem.

Posted by Sunigator on 08-07-2021 at13:14:


Originally posted by Tribun Dragon
Very well known problem.

Deactivate Num Lock before starting the game, this will solve the problem.

It works!! Thank you! Big Grin

I had already tried starting the game without the music patch, then deleting dosbox 0.63 and installing 0.65, then restarting without the patch from a previous savegame, finally restarting from the beginning, but the problem was still there (I was thinking of playing U5 from an old computer I still have!)

It is strange that I played U5 for some weeks without ever deactivating Num Lock.... and I had no trouble.

However thanks to the both of you for the help! Smile

Forum Software: Burning Board 2.3.6, Developed by WoltLab GmbH